Data Refresh issue on Reports

Incident Report for Blitzz

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 21:39 PDT

Investigating

We are currently investigating this issue.
Posted Apr 13, 2025 - 21:38 PDT

Identified

Our engineering team has identified the root cause and is actively backfilling the missing data. We apologize for the inconvenience and appreciate your patience.
Posted Apr 10, 2025 - 09:52 PDT

Investigating

We’re currently investigating an issue where data on the reporting page has not been refreshed for April 8th. Our team is actively working to identify the root cause and resolve it as quickly as possible.

We’ll provide an update as soon as we have more information.
Posted Apr 09, 2025 - 10:59 PDT
This incident affected: Reporting and Dashboard (Beta).