We’ve identified that the issue with video call recordings is caused by an ongoing AWS outage in the US region. Our team is actively working with AWS to mitigate the impact and restore normal service. Updates will be provided as recovery progresses.
Posted Oct 20, 2025 - 11:08 PDT
Investigating
Some Blitzz users may experience intermittent issues with video call recordings due to an ongoing AWS outage affecting the US region. Our team is working closely with AWS to restore full functionality. Recovery is in progress, and we’ll share updates as soon as more information becomes available.
Posted Oct 20, 2025 - 11:07 PDT
This incident affected: Video Connectivity (Recording Group Video Calls, Call Recordings, Video Recording Compositions).